sudo apt-get ‘installed’ !! :D

<p>Along with LibreHatti, we were also given tasks related to Latex. The first and the foremost thing to be done was supposed to be the installation of Latex. The installation wasn’t the tough part though it became one for me. :P<br /><br />
Just one command and it was supposed to be done. Mind this ! &lsquo;supposed to be done&rsquo; . :P<br /><br />
The command to install Latex is :</p>
<pre> <em>sudo apt-get install texlive-full</em></pre>
<p>If the installation is interrupted in between, you may resume it using the option fix-missing as :</p>
<pre> <em>sudo apt-get install –fix-missing texlive-full</em></pre>
<p>Every friend of mine had Latex installed on their laptops within 3-4 days of assignment of our tasks. But, I wasn’t, because of the errors I was encountering while installing or updating anything from terminal.<br /><br />
The errors were fresh for me. πŸ˜› I feared seeing them. Wanna have a look ?<br /><br />
Here it is :</p>
<pre> W: GPG error: http://archive.canonical.com precise Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key<br />
W: GPG error: http://ppa.launchpad.net precise Release: The following signatures were invalid: BADSIG BF36996C4E1F8A59 </p>
</pre>
<p>These errors were not limited to the installation of Latex. I encountered such signature errors, every time I tried to install or upgrade or update anything. Or, in a way, ‘sudo apt-get’ stopped working for me. :(</p>
<p>Whenever I tried to use :</p>
<pre> sudo apt-get update</p>
</pre>
<p>I encountered the error :</p>
<pre><em>The following signatures were invalid: NODATA 1 NODATA 2 </em></pre>
<p>I was surrounded by such signature errors. :(</p>
<p>I asked my friends about this but, none had an idea. As always, I came to Google for my rescue and was able to solve the issue in the 2nd attempt itself.<br />
Following is the 1st solution I tried (it didn’t work for me, but it might, for you ) :</p>
<p>1. First try :
<pre> sudo apt-key adv –recv-keys –keyserver keyserver.ubuntu.com 40976EAF437D05B5 </pre>
<p> <em>where 40976EAF437D05B5 is the number(key) written after the word BADSIG in the error statement.</em><br />
I tried finding the reason of why this didn’t work and I found something like (not very sure) :<br />
<em>BADSIG is different than NO_PUBKEY and the above method is meant for the latter, though it may work for the former.<br />
</em><br />
2. (this one worked for me) I tried the following set of commands :</p>
<pre>
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get update
</pre>
<p>These commands rebuild the cache, as I read. ‘Rebuild the cache ?’, I don’t really know, what it means. πŸ˜› I tried finding out, but didn’t find the answers much relevant. Answers are welcome ! πŸ˜‰ </p>
<p>After the execution of these commands, sudo apt-get started working and finally, I am done with the Latex installation. :)<br />
Apart from this, we’ve been assigned our new tasks related to ‘suspence’ in LibreHatti. I’m done with the models (and almost with the forms part ) and have pushed the changes. My new team includes Divyanshi and Aashita. Currently, they are busy with their Latex presentation and would join me tomorrow after delivering their awesome presentation. :)<br />
Let the ‘Suspense’ or ‘Suspence’ reveal !! ;)</p>

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s